Page 1 of 1

Full width kana not recognised as full width kana

Posted: December 1st, 2008 11:24 pm
by jkid
「お名前(カナ)名」は全角カナ文字で入力してください。


So on most electronic forms in Japanese you need to fill in your name in Full Width Kana. Not a problem one would think given the fact that you can simply select Full Width Kana in your IME and type it in.

However, for some odd reason despite selecting full width kana websites always generate errors saying "Please write in full width kana".

Does this happen to others or is it just me? I have literally been trying to fill out a form for like two hours because the thing won't accept how I've input the characters. I've had this problem before but I can't remember how I fixed it.

Posted: December 3rd, 2008 10:58 pm
by Rumpu
Make sure your browser is set to the right coding scheme.
You should at least try Shift-JIS and Unicode.

Posted: December 4th, 2008 3:43 pm
by jkid
Rumpu-san,
I tried both those encoding types as well as "auto select" and am still having no successes. I really need to be able to fill out forms, so any further suggestions would be very much appreciated. :)

Posted: December 4th, 2008 4:24 pm
by Rumpu
Could you give an URL of such a form ?
Which operating system / browser / input method do you use ?

Posted: December 4th, 2008 10:55 pm
by jkid
Rumpu-san,
Thanks again for the response, it suddenly started working in IE7 after changing the encoding to Shift JS and I think I must've also done something else because just changing the encoding didn't work at first. Unfortunately, I can't remember what it was I did but it seems to be working for now at least.

Firefox is my primary browser but it didn't seem to work in Firefox even when changing the encoding. I am not sure if it would work now or not after whatever change was made.

In any case, your suggestion seems to have fixed things so thank you very much. :)

Re: Full width kana not recognised as full width kana

Posted: August 21st, 2013 3:45 pm
by winter496807
Hello, I'm facing the same problem with the full width katakana not being able to be recognized. I've tried changing the encoding to Shift JIS and Unicode as well, but it's still not recognized. Is there any suggestion on how to solve this problem?